Board logo

標題: 將部 Server 升級左 PHP 版本 [打印本頁]

作者: A. Akiyama    時間: 2018-7-6 09:34     標題: 將部 Server 升級左 PHP 版本

呢個討論區同好多網站都係用 PHP 寫, 其中用到爛晒既版本就係 PHP 5 ...
如果冇用到新功能, 基本上 PHP 5 在 5.0 ~ 5.6 任何一個版本甚至 PHP 7 都可以行到 ...

始終而家 PHP 已經分成 5.5+ 同 7+ 兩大派系, 網站程式好多時需要兼顧晒兩個版本 ...
但 PHP 5.3, 5.4 比起 5.5, 5.6 就改左 D 野 (CODE 大部份都冇轉, 不過新 CODE 無法向下兼容)
結果兩年前我地都升級左做 5.5 版本 ...
到最近開始多左網站程式要求 5.6 (即 PHP 5 最後一個版本) 或 PHP 7 ...
咁我地都要焗住升埋做 PHP 5.6, 順便加埋 PHP 7.1 支援 ...
萬一有咩新網站程式需要 PHP 7 我地 Server 都可以行到
作者: 伊安    時間: 2018-7-6 16:16

辛苦晒丫
作者: A. Akiyama    時間: 2018-7-6 16:21

不過好可惜 5.5 同 5.6 速度只係快 4% 左右 ...
所以由於永討唔 Support PHP 7 既關係, 大家應該感受唔到快左 (雖然原本速度已經幾快)
作者: 伊安    時間: 2018-7-6 17:04

不過好可惜 5.5 同 5.6 速度只係快 4% 左右 ...
所以由於永討唔 Support PHP 7 既關係, 大家應該感受唔到快 ...
A. Akiyama 發表於 6-7-2018 16:21

同意
快4%速度我係感受唔到
作者: A. Akiyama    時間: 2018-7-7 01:05

原本都已經係 0.2 秒 ... 快 4% 鬼 Feel 到




歡迎光臨 永恆討論區 etnForum (https://www.etnforum.com/) Powered by Discuz! 7.2